Testing Outage

Incident Report for Clanwilliam Health Service

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 11:58 NZDT

Investigating

The test service is down for testing
Posted Apr 02, 2025 - 11:55 NZDT