Healthlink AUPD Outage
Incident Report for Clanwilliam Health Service
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 15:41 NZST
Investigating
Customers unable to access the Australian Provider Directory
Posted Sep 19, 2024 - 15:15 NZST
This incident affected: Australia - API Directory, Portal and RMSLite Services (HealthLink - AU Provider Directory (AUPD)).