ACC Claimlodgement Web Portal Down

Incident Report for Clanwilliam Health Service

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 08:19 NZDT

Investigating

We are currently investigating this issue.
Posted Mar 27, 2025 - 08:13 NZDT
This incident affected: New Zealand - Workplace, Portal & RMSLite Services (ACC Claim eLodgement Portal).