Electronic Special Authority Submission Failures

Incident Report for Clanwilliam Health Service

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 16:13 NZST

Investigating

Electronic Special Authority Submission Failures
Posted Apr 16, 2025 - 15:10 NZST
This incident affected: New Zealand - Health New Zealand Services (HealthLink - Electronic Special Authority).