Healthlink AU Forms Outage

Incident Report for Clanwilliam Health Service

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 14:35 NZDT

Investigating

Customers will getting error access the Healthlink AU Smartforms
Posted Mar 26, 2025 - 14:27 NZDT
This incident affected: Australia - HealthLink Smart Forms (HealthLink Smart Forms (AU)).